Bug 23243 - Image task should support mapper element
Summary: Image task should support mapper element
Status: RESOLVED FIXED
Alias: None
Product: Ant
Classification: Unclassified
Component: Optional Tasks (show other bugs)
Version: 1.7.0
Hardware: Other other
: P3 enhancement (vote)
Target Milestone: 1.8.0
Assignee: Ant Notifications List
URL:
Keywords: PatchAvailable
: 30373 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-09-18 11:50 UTC by Rob Oxspring
Modified: 2009-08-25 06:52 UTC (History)
1 user (show)



Attachments
Slight overhaul of image task adding mapper as we go (13.83 KB, patch)
2003-09-18 11:52 UTC, Rob Oxspring
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Oxspring 2003-09-18 11:50:51 UTC
A patch will follow shortly
Comment 1 Rob Oxspring 2003-09-18 11:52:57 UTC
Created attachment 8272 [details]
Slight overhaul of image task adding mapper as we go
Comment 2 Rob Oxspring 2003-09-18 11:58:15 UTC
Switched severity to enhancement.

The patch moves some of the logic so that there is less duplication in execute
() and now uses a processDir(...) rather than processFile(...) so that the 
logging uses the filenames without the absolute path.

The testcases now check for "Writing File" rather than "Processing File" since 
this is a more accurate description of whats going on.

Rob
Comment 3 Matt Benson 2005-08-01 16:48:33 UTC
*** Bug 30373 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Bodewig 2009-08-25 06:52:40 UTC
svn revision 807633