Bug 23445 - POI output crashes excel
Summary: POI output crashes excel
Status: RESOLVED DUPLICATE of bug 15375
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-pre3
Hardware: Sun other
: P3 major with 1 vote (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-09-26 19:31 UTC by pkitester
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pkitester 2003-09-26 19:31:25 UTC
Created a small Java program that runs a generic SQL statement and places the 
output of the statement into POI. When output file size from PIO is about 
1.6MB+ excel either crashes, hangs, or is unable to open the resulting file.

We have noticed that the JVM needs about 20 times the amount of RAM as the 
output size will be, this seems very inefficient. But having the resultant XLS 
file unreadable is worse.

With Office SR1 the file would typically crash or hang excel. With Office SR3 
the file would just not open, no error message either. We were able to get 
failing XLS files to open with OpenOffice.

Dropped down to POI 1.5.1 and the same code is working ok even with very large 
excel files. Tested to about 100k rows which was ~30mb xls file, but this took 
nearly 1 GB of RAM dedicated to the JVM and took about 45 minutes to run.
Comment 1 Avik Sengupta 2003-10-06 09:40:09 UTC

*** This bug has been marked as a duplicate of 15375 ***