Bug 24261 - Logs showing AcceptEx error caused by network name
Summary: Logs showing AcceptEx error caused by network name
Status: RESOLVED INVALID
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.0.47
Hardware: PC All
: P3 normal with 3 votes (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-30 17:18 UTC by Gary Penn
Modified: 2005-03-10 05:21 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gary Penn 2003-10-30 17:18:32 UTC
When running a live Apache 2.0.47 server I get the following error in my logs
approx 4 times per minute:

[warn] (OS 64)The specified network name is no longer available.  :
winnt_accept: Asynchronous AcceptEx failed.

No known cause.  Have researched issue in Google and in forums and bugzilla. 
Others have similar AcceptEx error but not usually with 2.0.47 w/the same
network name cause.

Not running any unusual network settings.  
Static IP, no viral software.  
W2K Advanced Server SP4
Comment 1 wai-lun kwok 2003-11-15 17:32:38 UTC
This may be related to this bug: 
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=21425

By the way, I'm running Apache 2.0.47, with PHP 4.3.4 on WinXP(SP1).
Comment 2 Jarrod Igou 2003-11-19 16:49:38 UTC
Apache 2.0.47, patched Windows 2000 Server (SP4), running Symantec Antivirus 
Corporate Edition, PHP 4.3.3.3, ActiveState Perl 5.8.0.806, MySQL 4.1.15 ; 
we're seeing this error, plus another.

[Mon Nov 10 10:05:06 2003] [warn] (OS 64)The specified network name is no 
longer available.  : winnt_accept: Asynchronous AcceptEx failed.
[Mon Nov 10 10:05:32 2003] [warn] (OS 121)The semaphore timeout period has 
expired.  : winnt_accept: Asynchronous AcceptEx failed.

The first one appears very frequently, but not regularly; sometimes it won't 
appear for hours, but then suddenly will appear in high frequency.

The second one is much less frequent, but is always accompanied with many of 
the first one. The difference: we see no performance difference with the first 
error; however, our monitoring software reports the site down when we see the 
second error. 

May or may not be related?

It always resets itself and is available again almost immediately. 

Comment 3 Holger Kramer 2003-11-19 18:36:41 UTC
Apache 2.0.48_OpenSSL0.97c, Windows 2000 Server (SP4), no Antivirus, behind
Loadbalancer, behind Firewall, ColdfusionMX.

a lot of (permanently) this messages...  always if there is some traffic...

[Mon Nov 10 17:50:41 2003] [warn] (OS 64)Der angegebene Netzwerkname ist
nicht mehr verfügbar.  : winnt_accept: Asynchronous AcceptEx failed.
[Mon Nov 10 17:50:54 2003] [warn] (OS 64)Der angegebene Netzwerkname ist
nicht mehr verfügbar.  : winnt_accept: Asynchronous AcceptEx failed.
[Mon Nov 10 17:51:24 2003] [warn] (OS 121)Das Zeitlimit für die Semaphore
wurde erreicht.  : winnt_accept: Asynchronous AcceptEx failed.
[Mon Nov 10 17:51:54 2003] [warn] (OS 121)Das Zeitlimit für die Semaphore
wurde erreicht.  : winnt_accept: Asynchronous AcceptEx failed.

hope this is no reilly bug, bye.
Comment 4 Erik Abele 2003-11-28 03:40:14 UTC

*** This bug has been marked as a duplicate of 21425 ***
Comment 5 Bryan Doxtdator 2004-10-01 05:00:12 UTC
Windows XP SP2
Apache 2

two errors i'm getting are

[warn] (OS 121)The semaphore timeout period has expired.  : winnt_accept:
Asynchronous AcceptEx failed.

AND 

[warn] (OS 64)The specified network name is no longer available.  :
winnt_accept: Asynchronous AcceptEx failed.
Comment 6 David D. Kilzer 2005-03-09 20:53:50 UTC
See also Bug 21425 (some working solutions for comments in Jan-Mar, 2005; an
earlier comment references a Microsoft KB article about potential ethernet
hardware issues) and Bug 24261.
Comment 7 Joe Orton 2005-03-10 14:21:02 UTC
Please see http://www.apache.org/dist/httpd/binaries/win32/#problems.