Bug 2435 - The Apply.jsp sample has two bugs
Summary: The Apply.jsp sample has two bugs
Status: CLOSED WONTFIX
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Unknown Taglib (show other bugs)
Version: unspecified
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-07-03 05:25 UTC by gniuhs
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gniuhs 2001-07-03 05:25:48 UTC
There are two problems I found when testing the example Apply.jsp. The example 
was tested on WebLogic 5.1 and NT 4.0 + SP4.

1) The example Apply.jsp comes with the component XSL does not work with the 
newest distribution of apache xalan-j_2_1_0 built in 05/23/2001.  The error I 
got is "java.lang.NoClassDefFoundError: org/apache/xalan/xslt/XSLTInputSource 
....". It works with the older versioin xalan-j_1_2_2 built in 12/1/2000.

2) The example failed to run until I modified the following line in the 
doEndTag() method in the ApplyTag.java.

Changed if (body != null) 
to      if (body != null && body.length() > 0)

The error I got is "
Input XSL; Line 1; Column 1
XSL Error: Could not parse Input XML document!
XSL Error: SAX Exception
Mon Jul 02 11:15:00 EDT 2001:<E> <WebAppServletContext-xsl> Root cause of Servle
tException
javax.servlet.jsp.JspException: org.apache.xalan.xslt.XSLProcessorException: The
 root element is required in a well-formed document."

Vivien Chen
Comment 1 Glenn Nielsen 2002-04-04 20:33:29 UTC
The XSL taglib requires Xalan 1.  Since there are better replacements such
as XTAGS or JSTL the XSL taglib will not be updated for Xalan 2 or TRAX.

The XSL taglib will be deprecated sometime in the near future.