Bug 24942 - Tomcat 5.0.16 / Windows 2000 Service does not start
Summary: Tomcat 5.0.16 / Windows 2000 Service does not start
Status: RESOLVED WORKSFORME
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Native:Integration (show other bugs)
Version: 5.0.14
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-24 16:42 UTC by Mr.Sea (Deniz TATAR)
Modified: 2005-10-16 00:50 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mr.Sea (Deniz TATAR) 2003-11-24 16:45:24 UTC
I downloaded jakarta-tomcat-5.0.14.exe and installed without any problem.
I have only j2sdk 1.4.2 and not jre. (But jre included with jdk you know)

After installation I opened the Windows 2000 "Services" tool and tried to start
"Apache Tomcat" service but it didn't start and I received following error 
message;

"Could not start the Apache Tomcat service on Local Computer. 
Error 1053: The service did not respond to the start or control request in a 
timely fashion."

I can start/stop Tomcat 5 with startup.bat and shutdown.bat without any problem.

I think there was a problem about tomcat.exe or tomcatw.exe service 
installation parameters. But I couldn't find any documentation about Windows 
NT/2000/XP Service Installation in currect documentation bundle.

For example if I want to use tomcat zip distribution (jakarta-tomcat-
5.0.14.zip) and make a manual installation (which it is better and flexible for 
me) I must know how to install the service with command line arguments. Or you 
can put a batch file for this, it will be very usefull.

I read "http://jakarta.apache.org/commons/daemon/procrun.html"  but I couldn't 
install tomcat5 service. I don't know what is the problem?

Thanks lot,
Comment 1 Remy Maucherat 2003-11-24 16:48:15 UTC
*** Bug 24943 has been marked as a duplicate of this bug. ***
Comment 2 Remy Maucherat 2003-11-24 16:52:36 UTC
If this cannot start, this likely means your JVM cannot be found for some reason
(you moved it manually maybe); the installation uses the registry keys to locate
your VM (pay special  attention to the JVM path being chosen at that time, this
won't work if it's not right).

I have yet to see this report be valid, so please use tomcat-user to debug this
more.
Comment 3 Yoav Shapira 2005-10-16 08:50:34 UTC
I've been running 5.0.28 with JDK 1.4 on Windows 2000 for years now.  If you're
still having problems, it's probably due to a misconfiguration.  As Remy
suggested, post your issue to tomcat-user and ask for help.