Bug 25136 - the <str:chomp> doesn't work anymore
Summary: the <str:chomp> doesn't work anymore
Status: RESOLVED FIXED
Alias: None
Product: Taglibs
Classification: Unclassified
Component: String Taglib (show other bugs)
Version: 1.0.1
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-02 13:18 UTC by Lionel Pieniazek
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Pieniazek 2003-12-02 13:18:13 UTC
Hi, 

I saw on the source of this tag and I note that use the StringUtils.chomp 
function of the common apache libs

The problem is that function change and there is other function to do the same 
functionality.

Is the function "StringUtils.substringBeforeLast(String, String)"

How shoud I change that or who could change the taglib?

Thanks

example:
<str:chomp delimiter="_">en_US</str:chomp>  --------> return es_US and must be 
en
Comment 1 Felipe Leme 2004-02-29 20:54:47 UTC
The problem is not with the function - I replaced it and the bug persists.

I will take a deeper look in the problem (and remove the deprecated methods anyway).

Comment 2 Felipe Leme 2004-02-29 23:40:09 UTC
Hi again,

Sorry, you're right, the problem was with the StringUtils.chomp() call.

I changed it and it works fine now.

I'm closing this bug and will open a generic one about all deprecated methods
that should be replaced.