Bug 25380 - Unzip task doesnt overwrite destination when file listing is root
Summary: Unzip task doesnt overwrite destination when file listing is root
Status: RESOLVED DUPLICATE of bug 28911
Alias: None
Product: Ant
Classification: Unclassified
Component: Core tasks (show other bugs)
Version: 1.6.0
Hardware: Other other
: P3 enhancement (vote)
Target Milestone: 1.8.0
Assignee: Ant Notifications List
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2003-12-10 02:26 UTC by Filip Hanik
Modified: 2009-08-24 08:27 UTC (History)
0 users



Attachments
ignoreRootFiles attribute added to Expand.java (1.63 KB, patch)
2003-12-10 02:27 UTC, Filip Hanik
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Hanik 2003-12-10 02:26:49 UTC
my patch makes it optional to force a file into the destination directory even
if the file listing inside the jar file is /file.txt

the attribute ignoreRootFiles can be set to true (default is false, same
behavior as now)

Haven't tested this on Windows, so the patch can be modified to handle those
cases too

Filip
Comment 1 Filip Hanik 2003-12-10 02:27:22 UTC
Created attachment 9478 [details]
ignoreRootFiles attribute added to Expand.java
Comment 2 Stefan Bodewig 2009-08-24 08:27:57 UTC

*** This bug has been marked as a duplicate of bug 28911 ***