Bug 25418 - couldn't grab the accept mutex
Summary: couldn't grab the accept mutex
Status: CLOSED DUPLICATE of bug 22484
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: All (show other bugs)
Version: 2.0.48
Hardware: HP HP-UX
: P3 blocker (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-10 18:13 UTC by Cristiano
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristiano 2003-12-10 18:13:22 UTC
Server version: Apache/2.0.48
OSystem version: HP-UX B.11.00 U 9000/800 unlimited-user license
During normal users activity there is this situation on my server:
root 19920     1  0 07:09:24 ?        0:01 /usr/local/apache2/bin/httpd -k start
www 19946 19920  0 07:09:45 ?         0:06 /usr/local/apache2/bin/httpd -k start
www 20199 19920  0 07:12:29 ?         0:06 /usr/local/apache2/bin/httpd -k start
www 19923 19920  0 07:09:25 ?         0:06 /usr/local/apache2/bin/httpd -k start
www 19925 19920  0 07:09:25 ?         0:08 /usr/local/apache2/bin/httpd -k start
www 19922 19920  0 07:09:25 ?         0:05 /usr/local/apache2/bin/httpd -k start
www 21517 19920  0 07:30:05 ?         0:06 /usr/local/apache2/bin/httpd -k start
www 19924 19920  0 07:09:25 ?         0:06 /usr/local/apache2/bin/httpd -k start
www 19945 19920  0 07:09:45 ?         0:06 /usr/local/apache2/bin/httpd -k start
www 19944 19920  0 07:09:44 ?         0:06 /usr/local/apache2/bin/httpd -k start
www 19921 19920  0 07:09:25 ?         0:06 /usr/local/apache2/bin/httpd -k start

after approximatly 50 minutes of activity the http process going to die and 
this is the messages in APACHEHOME/logs/error_log file.

[Tue Dec 09 08:01:58 2003] [emerg] (28)No space left on device: couldn't grab th
e accept mutex
[Tue Dec 09 08:01:58 2003] [alert] Child 7319 returned a Fatal error...
Apache is exiting!
[Tue Dec 09 08:01:58 2003] [emerg] (36)Identifier removed: couldn't grab the acc
ept mutex
[Tue Dec 09 08:01:58 2003] [emerg] (36)Identifier removed: couldn't grab the acc
ept mutex
[Tue Dec 09 08:01:58 2003] [emerg] (36)Identifier removed: couldn't grab the acc
ept mutex
[Tue Dec 09 08:01:58 2003] [emerg] (36)Identifier removed: couldn't grab the acc
ept mutex
[Tue Dec 09 08:01:58 2003] [emerg] (36)Identifier removed: couldn't grab the acc
ept mutex
[Tue Dec 09 08:01:58 2003] [emerg] (36)Identifier removed: couldn't grab the acc
ept mutex
[Tue Dec 09 08:01:58 2003] [emerg] (36)Identifier removed: couldn't grab the acc
ept mutex
[Tue Dec 09 08:01:59 2003] [emerg] (22)Invalid argument: couldn't grab the accep
t mutex
[Tue Dec 09 08:02:10 2003] [emerg] (22)Invalid argument: couldn't grab the accep
t mutex
[Tue Dec 09 08:02:11 2003] [emerg] (22)Invalid argument: couldn't grab the accep
 ecc. ecc. for every httpd process....

i don't have any file system near 100% used space; i don't have applied any 
patch of httpd (i have the most recent version); my c compiler is the cc ansi c 
compile of HP-UX 11.00;
please help me

thanks.
Comment 1 Jeff Trawick 2003-12-10 18:24:39 UTC
"No space left on device" is string for error ENOSPC, which is returned by some
SysV IPC functions like semaphore acquire...  so it isn't related to disk space
at all...  see comments (and advice) in previous PR


*** This bug has been marked as a duplicate of 22484 ***