Bug 25889 - JDBCStore hsqldb 1.7.1 connection faild and no connection reconnect after failed
JDBCStore hsqldb 1.7.1 connection faild and no connection reconnect after failed
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
5.0.16
Other other
: P3 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 7043 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-01-04 21:32 UTC by Peter Rossbach
Modified: 2010-12-13 17:31 UTC (History)
1 user (show)



Attachments
JDBCStore Patch (32.89 KB, patch)
2004-01-04 21:35 UTC, Peter Rossbach
Details | Diff
LocalProperties (401 bytes, patch)
2004-01-04 21:35 UTC, Peter Rossbach
Details | Diff
JDBCStore patch (928 bytes, patch)
2004-12-21 22:45 UTC, Tom Anderson
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Rossbach 2004-01-04 21:32:07 UTC
Add following feature:

1) The JDBC Store have no connection user and password arguments. Only with 
connectionURL hsql 1.7.1 not work.

2) after connection failed no auto reconnet.

s. patches

Peter
Comment 1 Peter Rossbach 2004-01-04 21:35:28 UTC
Created attachment 9794 [details]
JDBCStore Patch
Comment 2 Peter Rossbach 2004-01-04 21:35:55 UTC
Created attachment 9795 [details]
LocalProperties
Comment 3 Remy Maucherat 2004-01-09 11:35:47 UTC
I've applied your patch, which looked ok, but couldn't test it. Thanks.
Comment 4 Tom Anderson 2004-12-21 22:45:47 UTC
Created attachment 13815 [details]
JDBCStore patch

I recently upgraded to TC5.   But to my dismay, it started hammering my
database so hard that it was 
crashing periodically.	 Looking at the code for JDBCStore I noticed that it is
now running every single 
query twice even when it succeeds the first time.   I believe the intent was to
try to reconnect on a 
database error but the side effect is to create twice as many queries as needed
when the database is up.
Comment 5 Tom Anderson 2004-12-21 22:47:45 UTC
I have reopened this bug because of the problem introduced by it.   Specifically, each query is now 
being run twice even when the first one is successful.
Comment 6 Tom Anderson 2004-12-21 22:50:01 UTC
Comment on attachment 13815 [details]
JDBCStore patch

note: this patch should fix the bug introduced by the previous patch
Comment 7 Remy Maucherat 2005-01-07 16:18:11 UTC
I have applied the patch. Thanks.
Comment 8 Mark Thomas 2010-12-13 17:31:46 UTC
*** Bug 7043 has been marked as a duplicate of this bug. ***