Bug 26483 - Formula Parser barfs on 3DRefs because of lack of access to the internal workbook
Summary: Formula Parser barfs on 3DRefs because of lack of access to the internal work...
Status: RESOLVED DUPLICATE of bug 34944
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-pre3
Hardware: All All
: P3 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-28 05:15 UTC by Eric Ladner
Modified: 2005-05-19 07:33 UTC (History)
0 users



Attachments
Test case spreadsheet (6.50 KB, application/octet-stream)
2004-01-28 05:16 UTC, Eric Ladner
Details
Java example that tickles the bug (2.18 KB, text/plain)
2004-01-28 05:17 UTC, Eric Ladner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Ladner 2004-01-28 05:15:48 UTC
Attached is an Excel spreadsheet and a snippet of Java that shows the error.

it blows up on line 295 of FormulaParser:

  short externIdx = book.checkExternSheet(book.getSheetIndex(sheetName));

because there was no workbook to get the external sheet references from
(external reference meaning external to the sheet the formula is on.
Comment 1 Eric Ladner 2004-01-28 05:16:43 UTC
Created attachment 10104 [details]
Test case spreadsheet
Comment 2 Eric Ladner 2004-01-28 05:17:18 UTC
Created attachment 10105 [details]
Java example that tickles the bug
Comment 3 Avik Sengupta 2005-05-19 15:33:40 UTC

*** This bug has been marked as a duplicate of 34944 ***