Bug 27269 - Class names referred in TLD and JAR do not match
Summary: Class names referred in TLD and JAR do not match
Status: RESOLVED FIXED
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Random Taglib (show other bugs)
Version: 1.1
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-26 20:01 UTC by Madhav Iyer
Modified: 2009-08-17 02:03 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Madhav Iyer 2004-02-26 20:01:07 UTC
The class name RandomStrgTei is referred to in TLD file as RandomStrgTEI. This 
TLD is taglibs-random.tld and also the TLD file taglib.tld in taglibs-
random.jar.

I had to manually fix it to make it work.

Also, the following gives an array out of bounds exception:

<rand:string id="random3" charset="A-Z" length="15"/>
<jsp:getProperty name="random3" property="random"/>


- Madhav
miyer@nbme.org
Comment 1 Felipe Leme 2004-02-26 20:05:00 UTC
I will take a look on that...
Comment 2 Felipe Leme 2004-02-27 02:36:06 UTC
Madhav,

I fixed the TEI/Tei issue, but couldn't reproduce the ArrayOutOfBondsException.

So, righ now I'm closing this bug, but if you could provide more info (like
server version, stack trace, etc...) we can open a new one to investigate that
issue.

Regards,

Felipe