Bug 27453 - Custom doc properties get rearranged by Mutables
Summary: Custom doc properties get rearranged by Mutables
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HPSF (show other bugs)
Version: 3.0-dev
Hardware: PC Windows XP
: P3 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 30956 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-03-04 20:31 UTC by Jan Thunqvist
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments
Sample source and dest files used for WriteTitleAndAuthor (4.08 KB, application/zip)
2004-03-04 20:34 UTC, Jan Thunqvist
Details
Output from source and destination after WriteAuthorAndTitle (3.53 KB, text/plain)
2004-08-26 10:52 UTC, Jan Thunqvist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Thunqvist 2004-03-04 20:31:23 UTC
It seems like the MutablePropertySet(PropertySet) constructor re-arranges the 
custom document properties so that the destination file is corrupted (not sure 
if this is the reason for the corruption though). I just grabbed the source 
from the CVS, built it and tried out the WriteAuthorAndTitle example and got 
errors when I tried to add new custom doc properties to my destination file 
(in explorer). I am also unable to see the old custom doc props when I bring 
up the Properties dialog box in explorer.
Comment 1 Jan Thunqvist 2004-03-04 20:34:57 UTC
Created attachment 10667 [details]
Sample source and dest files used for WriteTitleAndAuthor
Comment 2 Rainer Klute 2004-06-09 18:10:13 UTC
Before writing a section's properties HPSF now sorts them by their property IDs.
Since I don't have M$ Word I cannot test this fix. Please try it out and let me
know if it helps!
Comment 3 Rainer Klute 2004-08-15 06:18:07 UTC
I didn't get an affirmation that the fix helped the reporter, but I also didn't
get any complaints, so I close this bug.
Comment 4 Jan Thunqvist 2004-08-26 10:51:34 UTC
Hi,

Sorry for the long delay, I haven't been at the office for a while...

The fix do arrange the properties by their id now, but I think (not sure here) 
that it is important to keep the order from the source document. I have 
checked in a text file with the output from ReadCustomPropertySets for both 
the source file test1.xls and the destination file test2.xls. No custom props 
are visible in test2.
Comment 5 Jan Thunqvist 2004-08-26 10:52:56 UTC
Created attachment 12536 [details]
Output from source and destination after WriteAuthorAndTitle
Comment 6 Rainer Klute 2004-08-31 13:07:50 UTC
*** Bug 30956 has been marked as a duplicate of this bug. ***