Bug 27921 - Unicode format support hidden from user-model
Summary: Unicode format support hidden from user-model
Status: RESOLVED DUPLICATE of bug 34007
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-FINAL
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-24 21:40 UTC by Peter M. Murray
Modified: 2005-04-28 08:42 UTC (History)
0 users



Attachments
proposed patch - not sure why all the diffs in StringUtil i just added a method. (23.56 KB, patch)
2004-03-24 21:44 UTC, Peter M. Murray
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter M. Murray 2004-03-24 21:40:29 UTC
When using the HSSF* classes, there doesn't appear to be an easy way to get 
FormatRecords to support unicode.  Analogous to Bug #22957, I propose that the 
FormatRecord automatically detect if unicode is needed.  Then, you don't need 
to expose the explicit unicode support.

I've attached a patch (including an extension to StringUtil to detect unicode 
required strings).
Comment 1 Peter M. Murray 2004-03-24 21:44:35 UTC
Created attachment 10963 [details]
proposed patch - not sure why all the diffs in StringUtil i just added a method.
Comment 2 Avik Sengupta 2005-04-28 16:42:40 UTC
Duplicate. fixed. 

*** This bug has been marked as a duplicate of 34007 ***