Bug 28117 - username for authentication is beeing wrongly escaped
Summary: username for authentication is beeing wrongly escaped
Status: CLOSED WORKSFORME
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_auth (show other bugs)
Version: 2.0-HEAD
Hardware: Other All
: P3 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-01 07:20 UTC by Sven Goldt
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Goldt 2004-04-01 07:20:14 UTC
If you have a user say Domain\username then a value of Domain\\username will be
passed to the underlying authentication module and so authentication doesn't
succeed.
This happens with every backslash given anywhere e.g. \username will be
translated to \\username.
The request_req *r contains the username in r->user and this is where the
authentication modules like mod_auth_ldap get the wrong username.
Comment 1 André Malo 2004-04-05 08:12:49 UTC
I cannot reproduce the problem. Perhaps you are confused because the error log
entries are escaped since 2.0.49 (see changelog)? beside other things,
backslashes will be duped in the error log output now.
Comment 2 André Malo 2004-04-10 21:53:52 UTC
No further response.