Bug 28258 - fmt:formatDate adds multiple content-language headers
Summary: fmt:formatDate adds multiple content-language headers
Status: RESOLVED DUPLICATE of bug 28248
Alias: None
Product: Taglibs
Classification: Unclassified
Component: I18N Taglib (show other bugs)
Version: 1.0
Hardware: All All
: P3 major (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-07 12:09 UTC by Antti Suanto
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Suanto 2004-04-07 12:09:18 UTC
When fmt:formatDate tag is used in jsp-page content-language header is added.
This is ok, but when formatDate tag is called multiple times, multiple
content-language headers are added. This causes that some browsers (including
IE) will not display the page.

The problem seems to be in SetLocaleSupport.getFormattingLocale which for some
reason calls setResponseLocale method and this sets content-language header.

This is tested with 1.0.3 and 1.0.5 versions.
Comment 1 Martin Cooper 2004-04-07 18:50:00 UTC

*** This bug has been marked as a duplicate of 28248 ***