Bug 28490 - Warning during precompile (Deployment Descriptor Is Malformed)
Summary: Warning during precompile (Deployment Descriptor Is Malformed)
Status: RESOLVED WORKSFORME
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: 1.0
Hardware: PC Windows XP
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-20 08:48 UTC by Harm Jan Nijlunsing
Modified: 2009-08-17 02:03 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harm Jan Nijlunsing 2004-04-20 08:48:04 UTC
Application Server: WebLogic 6.1SP4
Java compiler: Sun JDK 1.3.1_08

When precompiling JSP's (Or when the application server compiles during runtime)
We get the following warning continously:
[jspc] parsing /jsp/templates/include/accepted_cards.jsp:
<20-apr-04 10:36:16 CEST> <Warning> <HTTP> <Deployment descriptor is malformed, 
check against the DTD: org.xml.sax.SAXParseException: The content of element 
type "validator" must match "(validator-class,init-param*)"..>

When copying the validator section from c.tld to c-rt.tld the warning 
disappears. Both c.tld and c-rt seem to use the same DTD for validation, so 
probably there is an error in the c-rt.tld?

Output from the manifest.mf from the standard.jar
Manifest-Version: 1.0
Extension-Name: org.apache.taglibs.standard
Specification-Title: JavaServer Pages Standard Tag Library (JSTL)
Implementation-Vendor-Id: org.apache
Created-By: Ant 1.4.1
Implementation-Vendor: Apache Software Foundation
Specification-Version: 1.0
Implementation-Version: 1.0.3
Implementation-Title: jakarta-taglibs 'standard': an implementation of
  JSTL
Comment 1 Felipe Leme 2004-05-12 00:26:55 UTC
CC'ing the taglibs-dev address to all Standard bugs. 
Comment 2 Justyna Horwat 2004-05-14 21:37:10 UTC
The JSTL 1.0.x tag libraries conform to the http://java.sun.com/dtd/web-jsptaglibrary_1_2.dtd. I 
checked both the c.tld and c-rt.tld and they conform to the DTD.

What's odd is the error that Weblogic is throwing:

----
The content of element 
type "validator" must match "(validator-class,init-param*)"..>
----

That's not correct since the DTD specifies the validator element syntax as follows:

----
<!ELEMENT validator (validator-class, init-param*, description?) >
----

notice the optional "description" attribute which is valid according to the DTD but missing from the 
Weblogic error stack trace. 

This leads me to believe that there is a bug in Weblogic 6.1 SP4.
Comment 3 Harm Jan Nijlunsing 2004-06-21 10:07:03 UTC
Comments from BEA:

"The cause of this problem is 6.1 uses SERVLET 2.3 Second draft, the new syntax 
is in SERVLET 2.3 final version, which is used in 7.0. They will not be making 
changes to 6.1 to use the final version.  You must upgrade to 7.0."