Bug 28512 - Apache/2.0.49 (Unix) mod_ssl/2.0.49 OpenSSL/0.9.7d crash when the page have a special flash
Summary: Apache/2.0.49 (Unix) mod_ssl/2.0.49 OpenSSL/0.9.7d crash when the page have ...
Status: CLOSED DUPLICATE of bug 27945
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.0.49
Hardware: All Linux
: P3 critical (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL: http://www.todayisp.com/email/
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-21 13:39 UTC by sanry williams
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sanry williams 2004-04-21 13:39:41 UTC
I test for 2 days for this crash when I add SSL with apache2.0.49
That at last I find out that when apache2.0.49  display page :
http://www.todayisp.com/email/index.net  the apache2 will crash.

first I think it is the bug with php4.3.6 
but than I configure it with no php just html in 218.104.199.92/email2/
the apache2 still crash show up like the following 

At last I find out the reason is that this page have a special flash 
name in http://www.todayisp.com/email/images/promail2004.swf .
you can save as the page http://www.todayisp.com/email/index.net and
place it in the newly config apache2 , it will crash in IE6.0
  
cat error_log
[Wed Apr 21 21:30:32 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/images
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/share, referer: https://218.104.199.92/email2/
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/images, referer: https://218.104.199.92/email2/
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/news, referer: https://218.104.199.92/email2/
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/images, referer: https://218.104.199.92/email2/
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/product, referer: 
https://218.104.199.92/email2/
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/product, referer: 
https://218.104.199.92/email2/
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/images, referer: https://218.104.199.92/email2/
[Wed Apr 21 21:30:36 2004] [error] [client 219.235.211.237] File does not 
exist: /usr/local/apache2/htdocs/product, referer: 
https://218.104.199.92/email2/
[Wed Apr 21 21:30:37 2004] [notice] child pid 5046 exit signal Segmentation 
fault (11)
Comment 1 Joe Orton 2004-04-22 19:25:58 UTC
Can you get a core dump and a backtrace?

Fix for one known cause of segfaults in 2.0.49:

http://cvs.apache.org/viewcvs.cgi/httpd-2.0/modules/ssl/ssl_engine_io.c?r1=1.121&r2=1.122
Comment 2 Joe Orton 2004-06-01 21:21:23 UTC
Presume this is bug 27945.

*** This bug has been marked as a duplicate of 27945 ***