Bug 28652 - c:url generates invalid urls
Summary: c:url generates invalid urls
Status: RESOLVED DUPLICATE of bug 23319
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: 1.1
Hardware: Other All
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-28 10:59 UTC by Stefan Wachter
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Wachter 2004-04-28 10:59:03 UTC
If a url is constructed using the c:url and c:param tags then resulting the
resulting url is invalid. The problem is that the '&' character is not escaped
by using &. The result is for example:

<a href="http://localhost/test?a=1&b=2">test</a>

This is invalid XML because a parser expects the '&' character to start an
entity. Yet &b... is not a valid entity.
Comment 1 Pierre Delisle 2004-04-28 21:20:38 UTC

*** This bug has been marked as a duplicate of 23319 ***