Bug 28705 - PDF Text search doesnt work for embedded fonts.
Summary: PDF Text search doesnt work for embedded fonts.
Status: CLOSED DUPLICATE of bug 5335
Alias: None
Product: Fop - Now in Jira
Classification: Unclassified
Component: pdf (show other bugs)
Version: 0.20.5
Hardware: PC All
: P3 enhancement
Target Milestone: ---
Assignee: fop-dev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-30 08:06 UTC by anil gosavi
Modified: 2012-04-01 13:50 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description anil gosavi 2004-04-30 08:06:35 UTC
I am using FOP for PDF rendering and using Arial.xml and Arialbd.xml (metrics 
file) for embedding the Arial and Arial Bold font.
The FOP generates PDF correctly but the content with embedded font is not 
searachable.
Comment 1 Chris Bowditch 2004-04-30 08:30:33 UTC
This is a known issue. You can work around it in some cases, depending on the 
glyphs you are using in the Font. If you specify the -enc ansi option when 
generating the metrics files, copy, paste and search operations will work in 
PDF if you are only using characters in a very limited character set; I think 
this is iso-8859-1, but not absolutely certain.
Comment 2 Joachim Unger 2004-06-04 08:09:42 UTC
The bfrange-section in the metrics file was filled correctly. Can I use these 
values as a cmap section in the pdf?
Comment 3 Jeremias Maerki 2004-09-23 10:18:40 UTC
Cause: Missing ToUnicode maps.

*** This bug has been marked as a duplicate of 5335 ***
Comment 4 Glenn Adams 2012-04-01 13:50:23 UTC
batch transition to closed remaining pre-FOP1.0 resolved bugs