Bug 29016 - mod_disk_cache breaks images
Summary: mod_disk_cache breaks images
Status: RESOLVED DUPLICATE of bug 30278
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_cache (show other bugs)
Version: 2.0.49
Hardware: All All
: P3 major with 3 votes (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-15 23:31 UTC by John Calvi
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Calvi 2004-05-15 23:31:45 UTC
When using Apache 2.0.49 as a forward caching proxy with mod_disk_cache the 
cache over time breaks images (using IE 6). This can easily be repeated with 
the www.microsoft.com homepage. Proxy this page, then proxy alternate pages. At 
some point when returning to the microsoft page the cache will serve the page 
with broken images (i.e. images are not loaded). This does not occur with 
mod_mem_cache and I have repeated it on two different systems, Win 2003 & 
WinXP. It occurs with a vanilla apache setup, no extra modules loaded (besides 
proxy and caching modules of course). It occurs regardless of cache size or any 
setting I try with mod_cache or mod_disk_cache.

This may apply to other Apache 2.0.x versions. The problem did not occur with 
1.3.x. It renders Apache 2.0.x unusable for me as a caching proxy server unless 
I use only mod_mem_cache which not as desireable.
Comment 1 Michael Reinsch 2004-05-22 21:09:25 UTC
I see something similar with mod_cache and mod_disk_cache installed: the mime
type is not preserved. I can reproduce this by putting a style.css into the
DocumentRoot and using wget twice to retrive this file from a mod_disk_cache
enabled apache. The first content type of the first request is text/css, the one
of the second request text/plain.
Comment 2 Michael Alzheimer 2004-06-14 06:33:33 UTC
I can verify this behavior on
Apache 2.0.46 / 48 on Suse Linux 9.0
Apache 2.0.46 / 48 / 49 on Sun Solaris 9 (sparc)
Comment 3 Rüdiger Plüm 2004-08-18 11:13:12 UTC

*** This bug has been marked as a duplicate of 30278 ***