Bug 29114 - Error in Documentation on web related to web.xml
Summary: Error in Documentation on web related to web.xml
Status: RESOLVED WONTFIX
Alias: None
Product: Taglibs
Classification: Unclassified
Component: I18N Taglib (show other bugs)
Version: 1.0
Hardware: Other other
: P3 minor (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-20 12:06 UTC by Juan Manuel Merlos
Modified: 2009-07-10 00:35 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Manuel Merlos 2004-05-20 12:06:35 UTC
On http://jakarta.apache.org/taglibs/doc/i18n-doc/index.html (on-line docs)

on the configuration you say:

1) Copy the tag library descriptor file to the /WEB-INF subdirectory of your web
application.
2) Copy the tag library JAR file to the /WEB-INF/lib subdirectory of your web
application.
3) Add a <taglib> element to your web application deployment descriptor in
/WEB-INF/web.xml like this:

<taglib>
  <taglib-uri>http://jakarta.apache.org/taglibs/i18n-1.0</taglib-uri>
  <taglib-location>/WEB-INF/i18n.tld</taglib-location>
</taglib>

The problem is that I think <taglib-location> should be
"/WEB-INF/taglibs-i18n.tld" because on the dowloaded package, as default, has
that name.

I dowloaded the package from: 
http://cvs.apache.org/builds/jakarta-taglibs/nightly/projects/i18n/

Regards. Juan.
Comment 1 Henri Yandell 2009-07-10 00:35:56 UTC
JSTL replaced the i18n taglib, so this won't be worked on.