Bug 29207 - LDAP add-to-cache causes auth_ldap to return false negatives
Summary: LDAP add-to-cache causes auth_ldap to return false negatives
Status: CLOSED DUPLICATE of bug 24801
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ldap (show other bugs)
Version: 2.0-HEAD
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
: 18756 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-25 17:13 UTC by Graham Leggett
Modified: 2004-11-29 16:32 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Leggett 2004-05-25 17:13:48 UTC
The LDAP cache code is returning false negatives when the cache gets full.

There are two problems at work here:

- The cache purge code doesn't work, so the cache gets full and stays full.

- The add to cache function, failing because the cache is full, seems to be
causing Apache to return an auth denied, when it should really fail and log an
error, though auth the user (as there is no reason why a successfully auth'ed
user should be denied due to cache problems).

The segfaults that were caused by the above problems have been fixed, unmasking
the two problems.
Comment 1 Graham Leggett 2004-05-25 17:20:13 UTC
*** Bug 18756 has been marked as a duplicate of this bug. ***
Comment 2 Graham Leggett 2004-05-25 17:54:58 UTC
*** Bug 24801 has been marked as a duplicate of this bug. ***
Comment 3 Graham Leggett 2004-10-03 16:17:44 UTC
PR 24801 describes the problem with cache purge, fixed in HEAD and v2.0.53-dev.


*** This bug has been marked as a duplicate of 24801 ***