Bug 29225 - last() and position() inside xtag forEach
Summary: last() and position() inside xtag forEach
Status: RESOLVED DUPLICATE of bug 12620
Alias: None
Product: Taglibs
Classification: Unclassified
Component: XTags Taglib (show other bugs)
Version: 1.1
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-26 12:46 UTC by fabio sabbatini
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabio sabbatini 2004-05-26 12:46:01 UTC
I'm using jasp tag <xtags:forEach> to print a list of elements like in xsl-xml
transformation, and i would obtain something like this:

element1, element2, element3,  ... elementN (without ,)

I tried to use  <xtags:valueOf select="last()"/> and <xtags:valueOf
select="position()"/> to check if i am on the last element of the loop, but
doesn't work.

Both <xtags:valueOf select="last()"/> and <xtags:valueOf select="position()"/>
return always 0.

Thanks
Comment 1 Sven Rottenbiller 2004-08-23 21:00:26 UTC

*** This bug has been marked as a duplicate of 12620 ***