Bug 29336 - Unable to download PDF using MS IE 6 and SSL
Summary: Unable to download PDF using MS IE 6 and SSL
Status: RESOLVED DUPLICATE of bug 27122
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Connector:Coyote (show other bugs)
Version: 5.0.24
Hardware: PC Linux
: P3 critical (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-02 08:49 UTC by ingo
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ingo 2004-06-02 08:49:34 UTC
In my docbase I have a folder called "pdf" containing some PDF files. In my 
webapp I use some normal anchor-tags to link to those documents so that they 
get displayed in the browser or downloaded (depending on client configuration).

With Tomcat 4.1.X everything worked well but after switching to Tomcat 5.0.24 
the request of PDFs using Microsoft Internet Explorer 6.0.2800.1106 (SP1) now 
lead to errors. Just this (unfortunately very important) browser is now unable 
to display and/or download those PDF files. With Mozilla everything still works.

I use a SSL Coyote HTTP/1.1 connector on port 443. This SSL connector seems to 
be the problem - as a non-SSL-connector still works fine with all target 
browsers. Just SSL is the problem here.

        <Connector port="443"
                   maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
                   enableLookups="false" disableUploadTimeout="true"
                   acceptCount="100" debug="0" scheme="https" secure="true" 
URIEncoding="UTF-8">
          <Factory keystoreFile="/root/.keystore"
               keystorePass="changeit"
               clientAuth="false" protocol="TLS"/>
        </Connector>

Maybe I have a hint, too: in the past I experienced some problems with dynamic 
downloads perfomed by a servlet over SLL (using MS IE 6 as the client). MS IE 6 
seems to have a bug when downloading binary data over SSL. In my download-
servlet I had to turn of caching...

    response.setHeader("Expires", "0");
    response.setHeader("Cache-Control", "must-revalidate, post-check=0, pre-
check=0");
    response.setHeader("Pragma", "public");

...to get it to work with MS IE 6.

Again, everything worked fine under Tomcat 4.1.X with its original SSL 
connector (used by default up to version 4.1.27).

Best wishes

Ingo
Comment 1 william.barker 2004-06-02 16:06:09 UTC

*** This bug has been marked as a duplicate of 27122 ***