Bug 29788 - Random Segmentation Fault
Summary: Random Segmentation Fault
Status: CLOSED DUPLICATE of bug 27945
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: All (show other bugs)
Version: 2.0.49
Hardware: PC Linux
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-24 17:30 UTC by Roger Krolow
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Krolow 2004-06-24 17:30:59 UTC
Linux RHEL ES 3.0
Apache 2.0.49
PHP 4.3.7 and 4.3.4
Openssl 0.9.7d

Users claim that sometimes they click in a link and the page expires. We
couldn't reproduce the error. 

The site has about 200 page views per hour and the error happens random each few
minutes. See bellow the ocurrencies in one hour reported bye error_log:

[Thu Jun 24 11:02:52 2004] [notice] child pid 22148 exit signal Segmentation
fault (11)
[Thu Jun 24 11:08:22 2004] [notice] child pid 15348 exit signal Segmentation
fault (11)
[Thu Jun 24 11:18:14 2004] [notice] child pid 31772 exit signal Segmentation
fault (11)
[Thu Jun 24 11:25:43 2004] [notice] child pid 4113 exit signal Segmentation
fault (11)
[Thu Jun 24 11:29:23 2004] [notice] child pid 25547 exit signal Segmentation
fault (11)
[Thu Jun 24 11:45:03 2004] [notice] child pid 26063 exit signal Segmentation
fault (11)


We upgraded to Apache 2.0.49 recently, when the server hardware was upgraded. It
means that all the other software, including our PHP application, worked well
before.

After spending many hours trying to reproduce and isolate the problem, without
success, we moved back to Apache 2.0.48 and the error log stopped. No user has
claimed again yet.

I can't assure it is a specific Apache error... but the version change seemed to
solve the problem.

Regards,

Roger
Comment 1 Joe Orton 2004-06-25 15:00:40 UTC
2.0.49-specific segfaults on sites using SSL is probably bug 27945, where you
can find a link to a patch.

*** This bug has been marked as a duplicate of 27945 ***