Bug 29961 - DirectoryIndex'es fail to get proxied.
Summary: DirectoryIndex'es fail to get proxied.
Status: CLOSED DUPLICATE of bug 15112
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_dir (show other bugs)
Version: 2.0.46
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-07 21:38 UTC by Dmitri Tikhonov
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Tikhonov 2004-07-07 21:38:24 UTC
I have set up a dual apache system -- a front-end and a back-end that
runs CGI scripts.  I wanted to proxy all .cgi files in a directory,
including index.cgi, which is set up by DirectoryIndex.  I have the
following configuration:

  DirectoryIndex index.cgi
  <Location /index.cgi>
    ProxyPass http://127.0.0.1:8088/index.cgi
  </Location>

However, by default, this does not work:

  [root@plato root]# telnet localhost 80
  Trying 127.0.0.1...
  Connected to localhost.localdomain (127.0.0.1).
  Escape character is '^]'.
  GET / HTTP/1.1
  Host: plato

  HTTP/1.1 404 Not Found
  Date: Wed, 07 Jul 2004 19:26:14 GMT
  Server: Apache
  Content-Length: 198
  Content-Type: text/html; charset=iso-8859-1

  <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
  <html><head>
  <title>404 Not Found</title>
  </head><body>
  <h1>Not Found</h1>
  <p>The requested URL / was not found on this server.</p>
  </body></html>

This bug is similar to bug 15112, only the patch provided there does not work in
my case (not sure about mod_rewrite).  I found an old thread:
http://archive.apache.org/gnats/3596 which allowed me to patch mod_dir.c to
allow such proxying (note rr->proxyreq check).

It is not clear however, whether mod_dir or mod_proxy is to be fixed.
Comment 1 André Malo 2004-07-07 21:54:27 UTC

*** This bug has been marked as a duplicate of 15112 ***