Bug 30170 - Logfiles cannot be larger than 2GB
Summary: Logfiles cannot be larger than 2GB
Status: CLOSED DUPLICATE of bug 13511
Alias: None
Product: Apache httpd-1.3
Classification: Unclassified
Component: core (show other bugs)
Version: 1.3.31
Hardware: PC Linux
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-17 23:58 UTC by apache-bugzilla
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description apache-bugzilla 2004-07-17 23:58:06 UTC
ap_fdopen for logfiles does not specify O_LARGEFILE and therefore apache stops
working when logfiles grow > 2GB
Comment 1 apache-bugzilla 2004-07-18 00:00:33 UTC
ehmm the function is actually

ap_pfopen()

Comment 2 Joe Orton 2004-07-19 10:20:35 UTC
This is fixed in 2.0.50, not sure if anyone is interested in doing the work for
1.3 too.  Opening all files with O_LARGEFILE is probably a bad idea so I'd guess
it requires an interface change.
Comment 3 Joe Orton 2004-08-24 20:37:14 UTC

*** This bug has been marked as a duplicate of 13511 ***