Bug 31092 - ObjRecord.clone()
Summary: ObjRecord.clone()
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.5-FINAL
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 40508 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-09-07 15:03 UTC by Oliver Jonas
Modified: 2008-05-08 22:24 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Jonas 2004-09-07 15:03:32 UTC
Currently reads:

public Object clone()
    {
        ObjRecord rec = new ObjRecord();
        rec.subrecords = new ArrayList();

        for ( Iterator iterator = subrecords.iterator(); iterator.hasNext(); )
            subrecords.add(( (Record) iterator.next() ).clone());

        return rec;
    }

Guess it should read:

    public Object clone()
    {
        ObjRecord rec = new ObjRecord();
        rec.subrecords = new ArrayList();

        for ( Iterator iterator = subrecords.iterator(); iterator.hasNext(); )
            rec.subrecords.add(( (Record) iterator.next() ).clone());

        return rec;
    }
Comment 1 Jason Height 2004-09-24 03:33:22 UTC
I have committed a patch to fix this. Hopefully in the next few weeks i can work
though some of these smaller bugs in bugzilla to commit fixes.

Jason
Comment 2 Josh Micich 2008-05-08 22:24:07 UTC
*** Bug 40508 has been marked as a duplicate of this bug. ***