Bug 31331 - Controling the XML processor used by the XSLT element
Summary: Controling the XML processor used by the XSLT element
Status: RESOLVED DUPLICATE of bug 36653
Alias: None
Product: Ant
Classification: Unclassified
Component: Core tasks (show other bugs)
Version: 1.6.2
Hardware: Other other
: P3 enhancement (vote)
Target Milestone: 1.8.0
Assignee: Ant Notifications List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-21 09:20 UTC by Jens Stanstrup
Modified: 2008-11-24 08:38 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Stanstrup 2004-09-21 09:20:36 UTC
The factory element of the XSLT element enables us to define some of the
parameters of the XSLT processor, e.g. selecting which XML processor to use.

It would also be very convenient to be able to modify the features and
properties of the selected XML processor.
Comment 1 Patrick Wiederkehr 2008-10-01 06:05:28 UTC
I would also like to have a passthroug for features to the xml parser (eg xerces)

cause i need xerces to activate xinclude features.
Comment 2 Stefan Bodewig 2008-11-24 08:38:17 UTC
I think factory/attribute addresses the first use case.

the second part is a duplicate of bug 36653 even though it may have been stated earlier.

*** This bug has been marked as a duplicate of bug 36653 ***