Bug 31622 - collections which has no documents in it are not found if apache server with xindice dployment is shut down and restarted
Summary: collections which has no documents in it are not found if apache server with ...
Status: CLOSED DUPLICATE of bug 28783
Alias: None
Product: Xindice
Classification: Unclassified
Component: DB Engine (show other bugs)
Version: cvs head (1.1)
Hardware: PC Windows XP
: P3 normal
Target Milestone: ---
Assignee: Xindice Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-10 21:04 UTC by Christian Kloner
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Kloner 2004-10-10 21:04:38 UTC
I created the following sequence of collections on
xmldb:xindice://localhost:8080/db using apache tomcat 5.5:
gridminer
gridminer/001projectname
gridminer/001projectname/001workflowname
gridminer/001projectname/001workflowname/dt

then i added a document to the collection
gridminer/001projectname/001workflowname/dt and it worked fine. the document was
in the collection and i could query it. the rootcollections of dt like
gridminer, 001projectname and 001workflowname had no documents in it. then i
shut down the tomcat server and restarted it. after querying xindice i realized
that now only the gridminer collection was there. all other subcollections like
"001projectname" I could not query because they were not found! then i created
the above collections again and added in each collection a document, shut down
the server, restarted tomcat and all collections could be found. 

it seems that I need to add a document in each collection to make it´s
subcollections persistent eles i loose the documents of the subcollection if one
root collection has no documents in it. and this only if the server is shut down
and restarted! if the server is never shut down or never crachs, there is no
problem with that. but it can be a nasty thing if it happens. :(
Comment 1 Vadim Gritsenko 2004-10-29 18:50:51 UTC
What xindice version do you use?
Have you tried the same with current CVS head?
Comment 2 Vadim Gritsenko 2004-10-30 13:28:14 UTC
> We are using the version 1.1b4 of xindice for the tomcat (5.017 and 5.5) 
> server.

This issue has been fixed in the CVS.

*** This bug has been marked as a duplicate of 28783 ***