Bug 31623 - [PATCH] setclasspath.sh script os400 problems
[PATCH] setclasspath.sh script os400 problems
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
5.0.28
Macintosh All
: P3 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-10-10 22:35 UTC by James Berry
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments
Patch to setclasspath.sh (766 bytes, patch)
2004-10-10 22:36 UTC, James Berry
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Berry 2004-10-10 22:35:22 UTC
The setclasspath.sh script contains some questionable syntax in several areas where the $os400 
variable is tested.

These errors lead to warnings from bash/sh if os400 is not set, and additionally mean that the 
functionality doesn't work as intended (i.e. the test of the os400 variable at one point assumes that it 
may have a null/non-null value, and at another assumes that it will always have a valid value.

These changes add robustness by not assuming that os400 will always be set to a non-null value, and 
test it only against "true" when testing whether it is true.

Patch is attached.
Comment 1 James Berry 2004-10-10 22:36:00 UTC
Created attachment 13014 [details]
Patch to setclasspath.sh
Comment 2 Yoav Shapira 2004-10-14 17:35:50 UTC
OK, done on both the Tomcat 5.0 and 5.5 branches.  Thank you for submitting 
this patch.