Bug 31679 - If the argument of a CGI has two or more consecutive plus signs (+) it gets truncated.
Summary: If the argument of a CGI has two or more consecutive plus signs (+) it gets t...
Status: RESOLVED LATER
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_cgi (show other bugs)
Version: 2.0-HEAD
Hardware: PC All
: P3 enhancement (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL: http://131.106.1.74/webnative/listdir...
Keywords: MassUpdate
Depends on:
Blocks:
 
Reported: 2004-10-12 22:45 UTC by Erik Zapien
Modified: 2018-11-07 21:08 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Zapien 2004-10-12 22:45:40 UTC
I have seen this on Windows on 2.0.52 and 1.3.31. Irix and Solaris versions 
work fine. If you click on an URL like:

http://131.106.1.74/webnative/listdir?C:/raid/this+is+a+test++04

(user: erik, passwd: erik in case you want to connect)

(note the two space before 04 encoded as ++),

the listdir.exe cgi program only receives:

C:/raid/this is a test

as a parameter. The "  04" is truncated. In the apache log, the correct entry 
is made with the full argument, it only gets truncated when the cgi is called.

--Erik Zapien
Comment 1 Nick Kew 2004-10-12 23:41:26 UTC
How do we know it's not just a bug in your CGI?

What happens if you substitute a simple well-known CGI prog such as printenv?
Comment 2 Erik Zapien 2004-10-13 00:32:14 UTC
The perl version of printenv that comes with Windows Apache 2 only reads 
environment variables (which have no problems). It doesn't read arguments. So, 
I added code to that script to display the arguments passed. This is my 
resulting perl script that I used to test:

#!c:/Perl/bin/Perl.exe
##
##  printenv -- demo CGI program which just prints its environment
##

print "Content-type: text/plain\n\n";
foreach $var (sort(keys(%ENV))) {
    $val = $ENV{$var};
    $val =~ s|\n|\\n|g;
    $val =~ s|"|\\"|g;
    print "${var}=\"${val}\"\n";
}

$first_arg = shift @ARGV;
print "arg[0] = ", $first_arg, "\n";
$second_arg = shift @ARGV;
print "arg[1] = ", $second_arg, "\n";
$third_arg = shift @ARGV;
print "arg[2] = ", $third_arg, "\n";
$fourth_arg = shift @ARGV;
print "arg[3] = ", $fourth_arg, "\n";

If you do:
http://131.106.1.74/cgi-bin/printenv.pl?argument1+ignored1+ignored2+ignored3

You will see all 4 arguments after the env variables with no problems.

If you do:
http://131.106.1.74/cgi-bin/printenv.pl?argument1++ignored1+ignored2+ignored3

You only see the first one.

Let me know if you need more information.

Thanks,

--Erik Zapien
Comment 3 Nick Kew 2004-10-13 01:06:00 UTC
Ah, you're misusing ISINDEX.  The spec doesn't define double-+, it merely tells
us this is an optional feature of CGI.  The QUERY_STRING is correct in your
printenv.

I won't mark it INVALID in case someone wants to hack on it, but implementation
of an optional and obsolote feature seems more an Enhancement request than a Bug.
Comment 4 William A. Rowe Jr. 2018-11-07 21:08:22 UTC
Please help us to refine our list of open and current defects; this is a mass update of old and inactive Bugzilla reports which reflect user error, already resolved defects, and still-existing defects in httpd.

As repeatedly announced, the Apache HTTP Server Project has discontinued all development and patch review of the 2.2.x series of releases. The final release 2.2.34 was published in July 2017, and no further evaluation of bug reports or security risks will be considered or published for 2.2.x releases. All reports older than 2.4.x have been updated to status RESOLVED/LATER; no further action is expected unless the report still applies to a current version of httpd.

If your report represented a question or confusion about how to use an httpd feature, an unexpected server behavior, problems building or installing httpd, or working with an external component (a third party module, browser etc.) we ask you to start by bringing your question to the User Support and Discussion mailing list, see [https://httpd.apache.org/lists.html#http-users] for details. Include a link to this Bugzilla report for completeness with your question.

If your report was clearly a defect in httpd or a feature request, we ask that you retest using a modern httpd release (2.4.33 or later) released in the past year. If it can be reproduced, please reopen this bug and change the Version field above to the httpd version you have reconfirmed with.

Your help in identifying defects or enhancements still applicable to the current httpd server software release is greatly appreciated.