Bug 31895 - Input Taglibs fails W3C Validation
Summary: Input Taglibs fails W3C Validation
Status: RESOLVED FIXED
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Input Taglib (show other bugs)
Version: 1.0
Hardware: All other
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
: 36122 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-26 12:45 UTC by Tim Troy
Modified: 2005-08-10 15:19 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Troy 2004-10-26 12:45:55 UTC
Page input-examples/form.jsp does not pass W3C validator found at link 
http://validator.w3.org/file-upload.html.

<select name="choice" >
<option value="2" selected="true">two</option>
<option value="1">one</option>
<option value="3">three</option>
</select>

Favorite letter?  &nbsp;&nbsp;&nbsp
<input type="radio" name="radio" value="a" checked="true" />a 
<input type="radio" name="radio" value="b" />b
<input type="radio" name="radio" value="c" />c
<input type="radio" name="radio" value="d" />d

Line 46, column 32: value of attribute "SELECTED" cannot be "TRUE"; must be one 
of "SELECTED"

<option value="2" selected="true">two</option>

The value of the attribute is defined to be one of a list of possible values 
but in the document it contained something that is not allowed for that type of 
attribute. For instance, the “selected” attribute must be either minimized 
as “selected” or spelled out in full as “selected="selected"”; a value 
like “selected="true"” is not allowed.


Line 61, column 56: value of attribute "CHECKED" cannot be "TRUE"; must be one 
of "CHECKED"

<input type="radio" name="radio" value="a" checked="true" />a

The value of the attribute is defined to be one of a list of possible values 
but in the document it contained something that is not allowed for that type of 
attribute. For instance, the “selected” attribute must be either minimized 
as “selected” or spelled out in full as “selected="selected"”; a value 
like “selected="true"” is not allowed.
Comment 1 Karl von Randow 2004-10-26 22:12:11 UTC
checked and selected attributes changed (finally) to valid values.
Comment 2 Karl von Randow 2005-08-10 23:19:19 UTC
*** Bug 36122 has been marked as a duplicate of this bug. ***