Bug 31979 - {urgent help needed .....}poi library does not support form objects properly.
Summary: {urgent help needed .....}poi library does not support form objects properly.
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.5-FINAL
Hardware: Other other
: P3 critical (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-30 00:31 UTC by as
Modified: 2007-01-16 01:41 UTC (History)
0 users



Attachments
input file to reproduce this problem (71.00 KB, application/octet-stream)
2004-10-30 00:34 UTC, as
Details
output file generated by this. (71.00 KB, application/octet-stream)
2004-10-30 00:35 UTC, as
Details

Note You need to log in before you can comment on or make changes to this bug.
Description as 2004-10-30 00:31:52 UTC
I read a excel file having one form object and rewrite that again using 
workbook.write() method.The output file which gets generated looks ok but when 
you try to save that file you get a excel message that 'document not saved' and 
then when you try to close the file , you get the visual basic message 'file 
not found'
The strange  thing is that output file works fine if you change the name of 
form to something else.The file which does not work has form 
named 'frmRROptions' and if you change this form name to something else 
say 'mytestform' and then execute the attached code , the generated output file 
behaves ok i.e; you don't get any excel or vb message and file saves.

It looks like poi library cannot read or write the form objects properly..

I am attaching the input file required to reproduce this problem and the output 
file generated..

Here is the code i used.
*********
FileInputStream fileInputStream = new FileInputStream(new File
("C://docs/UW_Latest.xls"));
HSSFWorkbook workbook = new HSSFWorkbook(fileInputStream,true);

FileOutputStream fos1 = new FileOutputStream(new File
("c://docs//uw_output.xls"));

workbook.write(fos1);
    fos1.close();

I am attaching the input and output file.
Comment 1 as 2004-10-30 00:34:43 UTC
Created attachment 13271 [details]
input file to reproduce this problem
Comment 2 as 2004-10-30 00:35:22 UTC
Created attachment 13272 [details]
output file generated by this.
Comment 3 as 2004-11-01 15:14:22 UTC
Please have a look at this defect..It is very for the my assignment.
Comment 4 as 2004-11-08 05:49:12 UTC
guys...help please...
Comment 5 Avik Sengupta 2004-11-18 14:53:11 UTC
Ashish, 

This is open source, so you'll have to live with the fact that other people's
schedules wont match yours :(

However, can I ask, have you tried to re-write the file with either ver 2.0, or
latest CVS HEAD?

Comment 6 Avik Sengupta 2007-01-16 01:41:46 UTC
Works as of 12Jan2007, Testcase added. 
http://issues.apache.org/bugzilla/show_bug.cgi?id=41366