Bug 32445 - Administration tool is not opened on browser at all.
Administration tool is not opened on browser at all.
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Administration
5.0.30
All All
: P1 critical with 1 vote (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 32448 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-11-30 10:08 UTC by Kan Ogawa
Modified: 2005-03-14 07:19 UTC (History)
4 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kan Ogawa 2004-11-30 10:08:29 UTC
I installed Tomcat 5.0.30, and customized tomcat-users.xml only.
When I open Tomcat administration tool (/admin) on web browser, 
jsp exception occurs and a blank page is displayed.

javax.servlet.jsp.JspException: Cannot find message resources under key 
org.apache.struts.action.MESSAGE [*1]
    at org.apache.struts.taglib.TagUtils.retrieveMessageResources
(TagUtils.java:1233)
    at org.apache.struts.taglib.TagUtils.message(TagUtils.java:1082)
    at org.apache.struts.taglib.bean.MessageTag.doStartTag(MessageTag.java:226)
    at admin.login_jsp._jspx_meth_bean_message_0(login_jsp.java:131)
    at admin.login_jsp._jspService(login_jsp.java:78)
    at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter
(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.ApplicationDispatcher.invoke
(ApplicationDispatcher.java:696)
    at org.apache.catalina.core.ApplicationDispatcher.processRequest
(ApplicationDispatcher.java:474)
    at org.apache.catalina.core.ApplicationDispatcher.doForward
(ApplicationDispatcher.java:409)
    at org.apache.catalina.core.ApplicationDispatcher.forward
(ApplicationDispatcher.java:312)
    at org.apache.catalina.authenticator.FormAuthenticator.authenticate
(FormAuthenticator.java:220)
    at org.apache.catalina.authenticator.AuthenticatorBase.invoke
(AuthenticatorBase.java:504)
 ......

[*1] In fact, the error message translated into Japanese is printed out.


Regards,
Kan Ogawa
Comment 1 E. Lefty kreouzis 2004-11-30 15:04:25 UTC
*** Bug 32448 has been marked as a duplicate of this bug. ***
Comment 2 Yoav Shapira 2004-11-30 17:48:15 UTC
This probably has to do with us (me ;)) making the admin webapp work with 
Struts 1.2 ;(  Any more details you can provide would be helpful.  Until then, 
if you need the admin webapp you might want to drop back to 5.0.28.
Comment 3 Yoav Shapira 2004-11-30 19:21:32 UTC
I reproduced the issue you reported on my Solaris and Windows boxes, both in 
the English locale.  So we definitely have a serious issue here.  The top of my 
stack trace is

WARNING: Unexpected error forwarding to login page
javax.servlet.ServletException: Cannot find messages under key 
org.apache.struts.action.MESSAGE
at org.apache.jasper.runtime.PageContextImpl.doHandlePageException
(PageContextImpl.java:846)
at org.apache.jasper.runtime.PageContextImpl.handlePageException
(PageContextImpl.java:779)
at admin.login_jsp._jspService(login_jsp.java:115)

Looking at the struts.jar version for the admin webapp, it's 1.2.4 as intended.
Comment 4 Amy Roh 2004-11-30 21:28:15 UTC
Fixed in the workspace.  Try the following patch to make it work with 5.0.30
bundle in jakarta-tomcat-5.0.30\server\webapps\admin\WEB-INF\struts-config.xml.

Index: struts-config.xml
  ===================================================================
  RCS file:
/home/cvs/jakarta-tomcat-catalina/webapps/admin/WEB-INF/struts-config.xml,v
  retrieving revision 1.6
  retrieving revision 1.6.2.1
  diff -u -r1.6 -r1.6.2.1
  --- struts-config.xml 17 Apr 2004 02:50:41 -0000 1.6
  +++ struts-config.xml 30 Nov 2004 20:24:00 -0000 1.6.2.1
  @@ -1,8 +1,8 @@
   <?xml version="1.0" encoding="ISO-8859-1" ?>
   
   <!DOCTYPE struts-config PUBLIC
  -          "-//Apache Software Foundation//DTD Struts Configuration 1.0//EN"
  -          "http://jakarta.apache.org/struts/dtds/struts-config_1_0.dtd"> 
  +          "-//Apache Software Foundation//DTD Struts Configuration 1.2//EN"
  +          "http://struts.apache.org/dtds/struts-config_1_2.dtd">
   
   
   <struts-config>
  @@ -1058,5 +1058,8 @@
   
   
     </action-mappings>  
  +
  +  <message-resources
  +    parameter="org.apache.webapp.admin.ApplicationResources"/>
       
   </struts-config>
Comment 5 Srgjan Srepfler 2004-12-09 13:01:29 UTC
Once installed the struts-config.xml I have the application loading but once
logged in, the tree menu on the left fails to react to any action. 

localhost_admin_log.2004-12-09.txt: this is the log of actions I clicked, I'm
not pasting the other logs as there were no error or exceptions.

2004-12-09 06:00:30 StandardContext[/admin]action: Entered
TreeControlTestAction:perform()
2004-12-09 06:00:30 StandardContext[/admin]action: Tree expand/contract on 
2004-12-09 06:00:54 StandardContext[/admin]action: Entered
TreeControlTestAction:perform()
2004-12-09 06:00:54 StandardContext[/admin]action: Tree expand/contract on 
2004-12-09 06:00:56 StandardContext[/admin]action: Entered
TreeControlTestAction:perform()
2004-12-09 06:00:56 StandardContext[/admin]action: Tree expand/contract on 
Comment 6 Yoav Shapira 2004-12-09 14:20:04 UTC
There's already a different bug open, and resolved in CVS, for what you're 
reporting.