Bug 32532 - tomcat logging page fails to mention need of commons-logging.jar in common/lib
tomcat logging page fails to mention need of commons-logging.jar in common/lib
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Documentation
5.5.4
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-12-04 21:35 UTC by Allistair Crossley
Modified: 2004-12-07 08:38 UTC (History)
0 users



Attachments
adds note to acquire commons-logging, modifies some other parts lightly (3.81 KB, patch)
2004-12-04 21:36 UTC, Allistair Crossley
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Allistair Crossley 2004-12-04 21:35:27 UTC
a few users have complained that the instructions on tomcat 5.5's new logging 
page does not produce the log files. i have tested this and they are correct. 
the problem is not the configuration properties but that the instructions only 
mention the requirement of placing log4j.jar in common/lib when in fact 
commons-logging.jar in common/lib is *also* required.

i have tested this on a fresh 5.5.5 a moment ago by copying the configuration 
on the logging page, and just adding commons-logging and this resolves this 
problem.

i am also interested if perhaps a tomcat dev could explain why a log4j 
configuration will not work on tomcat startup unless commons-logging is also 
in common/lib.
Comment 1 Allistair Crossley 2004-12-04 21:36:38 UTC
Created attachment 13647 [details]
adds note to acquire commons-logging, modifies some other parts lightly

to prevent further complaints, is there any way we can patch the website file
easily soon?
Comment 2 Remy Maucherat 2004-12-04 22:02:17 UTC
Actually, and this is more accurate, what you would need in the commons-logging
wrapper for the logging implementation you're using (commons-logging.jar has the
log4j wrapper).

As for the startup thing, it's likely caused by the context classloader which is
bound.
Comment 3 Remy Maucherat 2004-12-04 22:03:24 UTC
(In reply to comment #2)
> in

in -> is
Comment 4 Yoav Shapira 2004-12-07 17:38:26 UTC
OK, patch applied (slightly modified), in time for 5.5.6.