Bug 32534 - [crit] (98)Address already in use: make_sock: could not bind to port 80
Summary: [crit] (98)Address already in use: make_sock: could not bind to port 80
Status: RESOLVED INVALID
Alias: None
Product: Apache httpd-1.3
Classification: Unclassified
Component: Auth/Access (show other bugs)
Version: HEAD
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2004-12-05 10:36 UTC by Jari Korpi
Modified: 2007-06-25 16:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jari Korpi 2004-12-05 10:36:17 UTC
I upgrade my debian system for apache 1.3.33 and when i go http://example.com/
it's say "You don't have permission to access / on this server" ...and when i go
http://example.com/index.php it's work fine... 

Error log says: [crit] (98)Address already in use: make_sock: could not bind to
port 80

Before upgrade it works fine...not anymore.
Comment 1 André Malo 2004-12-05 11:09:34 UTC
Looks like a bug in you configuration. Please address this question to a user forum.
Comment 2 mauricev 2007-06-23 15:51:52 UTC
This is not a bug, but it's actually TWO bugs.

First, configuration changes shouldn't cause a program to fail. That's apache's
fault. It should know how its configuration is changing, know how to handle a
configuration from a previous version.

Second, the message isn't true. There is no problem binding to any ports. Apache
is just getting multiple Listen directives. It should see this and report that
and not claim it can't bind to a port that is open and available.When there
really is some program other than Apache bound to the port, then this message is
valid.
Comment 3 Nick Kew 2007-06-24 04:19:41 UTC
1. This is not a discussion forum.
2. What relevance does this incoherent tosh have to the original underspecified
report?
Comment 4 mauricev 2007-06-25 16:05:11 UTC
I'm opening my issue as a new bug,
http://issues.apache.org/bugzilla/show_bug.cgi?id=42737.