Bug 32845 - Investigate migration of tasks to usecases
Investigate migration of tasks to usecases
Status: RESOLVED FIXED
Product: Lenya
Classification: Unclassified
Component: Scheduler
Trunk
PC Windows XP
: P2 normal
: 1.4
Assigned To: Lenya Developers
:
: 29118 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-12-26 18:13 UTC by Gregor J. Rothfuss
Modified: 2005-04-24 12:58 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor J. Rothfuss 2004-12-26 18:13:00 UTC
Investigate whether the current Task / AntTask architecture can be superceded by
the new Usecase Framework. Study the implications for scheduler overhaul
(integration with cron block?)
Comment 1 Gregor J. Rothfuss 2005-01-26 17:12:43 UTC
*** Bug 29118 has been marked as a duplicate of this bug. ***
Comment 2 Gregor J. Rothfuss 2005-01-26 17:13:13 UTC
from 29118:

a lot of the ant tasks in lenya do not make sense and should be refactored into
classes. for instance, the save-meta-data ant task has to be redefined for every
publication (in config/tasks/targets.xml)

while ant has advantages for quickly whipping up tasks (say for exporting
content) it should not be a core part of lenya. we need to find a way to get rid
of these ant tasks while still allowing for easy customization / scripting.
Comment 3 Gregor J. Rothfuss 2005-03-21 03:43:23 UTC
there is now a lenya task that has access to the service manager. this allows to
use the lenya api from tasks
Comment 4 Gregor J. Rothfuss 2005-04-24 20:58:06 UTC
this has been fixed