Bug 33085 - new Host without restarting Tomcat
new Host without restarting Tomcat
Product: Tomcat 4
Classification: Unclassified
Component: Webapps:Administration
PC Linux
: P3 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
Depends on:
  Show dependency tree
Reported: 2005-01-13 18:19 UTC by lionel farbos
Modified: 2005-03-11 11:21 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description lionel farbos 2005-01-13 18:19:01 UTC
I'd want to create and deploy new Virtual(s) Host(s) and Contexts without having
to restart the entire Tomcat Server (4.1.31 or 5.0.28). 
This works if my Host(s) exist in server.xml when I start Tomcat.

BUT, if I want to create and deploy new Hosts before deploying new Contexts, 
I don't succeed (I tried this with the Tomcat Admin tool and the Tomcat Manager

In my test, I create a new Host (myHOST) with the Tomcat Admin tool. 
I put a manager Context into it. 

The problem is :
With the Admin GUI, it's not possible to put privileged=true !! 

so, when I launch http://myHost:8080/manager/html/list,
I have a SecurityException because the HTMLManagerServlet is privileged 
and cannot be loaded by this web app...

So, the new feature consist in : add the privileged property within the tomcat
Admin form.

Note : it is the same with Tomcat 5.0.28.
Comment 1 Mark Thomas 2005-01-15 00:58:12 UTC
Fixed in TC4.1.x and TC5.5.x
Comment 2 lionel farbos 2005-01-20 14:45:45 UTC
I thought TC5.5 was the developpement version and TC5.0 was the stable version
for the servlet 2.4...
If it is so, is it possible to fix this problem in TC5.0.30 ?
Comment 3 Mark Thomas 2005-01-20 23:39:10 UTC
As per http://jakarta.apache.org/tomcat/index.html

5.5.4 is the latest stable TC5 release. 5.5.x is now the focus of development

An explanation of the differences between 5.0.x and 5.5.x is also given.
Comment 4 lionel farbos 2005-03-11 12:18:37 UTC
I'd want to get the latest version of TC4.1 Manager.
Where is it ? jakarta-tomcat-4.0 ? (is yes, which tag) ?

I search within http://jakarta.apache.org/site/cvsindex.html
If I am right :
jakarta-tomcat is for TC3.2 and TC3.3
jakarta-tomcat-4.0 is for TC4.0 (and TC 4.1?)
jakarta-tomcat-5 is for TC5.0 and TC5.5
jakarta-tomcat-catalina is for TC5.0 ?
Comment 5 Mark Thomas 2005-03-11 20:21:21 UTC
This is a question for the tomcat-user mailing list.

Also, please do not add people to the CC list without their permission. It is
both rude and inconsiderate. If they want to add themselevs they will.