Bug 33317 - wrong column count (lastcol & dimensions)
Summary: wrong column count (lastcol & dimensions)
Status: RESOLVED DUPLICATE of bug 43901
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: unspecified
Hardware: PC Windows 98
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-31 22:32 UTC by wolf
Modified: 2008-05-10 20:17 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wolf 2005-01-31 22:32:33 UTC
this is copied frome gmane.comp

hi wolf, 

I too faced the same problem, this problem happens only with POI generated 
Excel Documents, If I opened the POI generated excel document and made some 
changes, that file column count is taking very correctly.

Regards,

Balaji


"Wolf Fietz" <info@technosoft-hofbieber.de> wrote in message news:ctcur4
$hff$1@sea.gmane.org...
> hi all,
> 
> there's a strange behaviour counting columns before readung excel tables :
> 
> i refer to the examples given for reading and writing excel-sheets
> if an excel table is manually generated , my be in this form :
> 
> a1 b1 c1 d1
> a2 b2 c2 d2
> a3 b3 c3 d3
> 
> the dimensions record counts 4 columns, so far ok
> 
> but if the above table is automatically generated by hssf writer,
> is says 3 columns instead of four  !?
> 
> columnwidth and formats are all set well for every cell, but modifying
> it takles no effect
> 
> Only, if this automatic-genearated table is manually saved a 2nd time, then
> suddenly
> the column-count work correctly again !
> 
> what i wonder about is, that only Label-SSTRecord and additionally
> NumberRecord
> is read in a serial  manner,
> 
> but not SST-record, this reads a1 a2  a3 and then b1 c1 d1 b2 c2 b3 c3 d2 d3
> ..
> for such behaviour any storing algorithm seems heavily to be found
> 
> what reason for this ?
> what can i do to get correct column-count ?
> 
> regards
> from wolf

this is copied to tell that more than one person has ths seen this bug(?)
it is severe as i wanted use this for easily edit contents of PDA-databases
so i have to read and write with hssf ,

whats a really fine tool, indeed !

regards from wolf
Comment 1 Avik Sengupta 2005-05-20 15:27:04 UTC
Sorry, dont understand what exactly the issue is here. Can you provide some
small piece of code with expected and actual results. thanks. 
Comment 2 Josh Micich 2008-05-10 20:17:11 UTC
fixed with bug 43901 (svn r634617)

Took a lot of convincing that something was wrong.

*** This bug has been marked as a duplicate of bug 43901 ***