Bug 33522 - Unable run a web module when you want to use javac
Unable run a web module when you want to use javac
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
5.5.7
PC Linux
: P3 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-02-11 16:34 UTC by Petr Pisl
Modified: 2005-03-30 09:51 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2005-02-11 16:34:34 UTC
This issue is only on unix/linux systems. When you remove the jdt parser and
want to use javac, then the web modules don't work, because the tomcat doesn't
have tools.jar on the classpath. According to the documentation it should be
sufficient delete the jasper-compiler-jdt.jar and copy the ant.jar.

In the setclasspath.sh is now condition, which is not true and the tools.jar is
not put on the classpath.
Comment 1 Yoav Shapira 2005-02-18 15:10:04 UTC
Can you please point to the specific area of the docs you'd like updated, and 
what you would like them to say?

In general, we expect that a user competent enough to remove the JDT compiler 
is also competent enough to replace it as needed for his/her use-case, making 
this not a Tomcat bug.  But if the doc is incorrect I'd like to fix that.
Comment 2 Yoav Shapira 2005-03-30 14:30:44 UTC
Guess not.
Comment 3 Petr Pisl 2005-03-30 17:27:14 UTC
I'm sorry for the late response. I didn't catch your previous comment.

On this page
http://jakarta.apache.org/tomcat/tomcat-5.5-doc/printer/jasper-howto.html there
is text:

"Apache Ant, which was used in previous Tomcat releases, can be used instead
instead of the new compiler by simply removing the
common/lib/jasper-compiler-jdt.jar file, and placing the ant.jar file from the
latest Ant distribution in the common/lib folder. "

I think, that this is not problem in documentation, because on windows machine
it works. The problem is in the setclasspath.sh.

My problem is, that we bundle the tomcat with Netbeans IDE and we want to use
Ant base compiler. 
Comment 4 Remy Maucherat 2005-03-30 17:30:47 UTC
We removed the dependency on JAVA_HOME. If you want to use that, please tweak
the script or classpath accordingly.
Comment 5 Karel Zikmund 2005-03-30 18:40:18 UTC
It is not necessary to tweak script - you can just use 'javac' parameter for
catalina.sh.
It is definitely bug in documentation - doesn't matter if tweaking script is the
right solution or not. Don't know if there's better category for documentation
bugs - please reassign if true. Thanks.
Comment 6 Yoav Shapira 2005-03-30 18:51:54 UTC
Jasper-howto updated to mention the "javac" switch to catalina.sh, will be
reflected in 5.5.10.