Bug 33738 - external-graphic worked until v20.1a to PCL render, now fails
Summary: external-graphic worked until v20.1a to PCL render, now fails
Alias: None
Product: Fop - Now in Jira
Classification: Unclassified
Component: images (show other bugs)
Version: 0.20.5
Hardware: All Linux
: P3 major
Target Milestone: ---
Assignee: fop-dev
Keywords: XSLTBug
Depends on:
Reported: 2005-02-25 01:41 UTC by Michael Leib
Modified: 2012-04-01 06:32 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Michael Leib 2005-02-25 01:41:40 UTC
I have seen this reported on ticket #33164, but thought (since this is a
work-stoppage for me) I would add some more information and re-open this hot 
item. I cannot upgrade to anything past v20.1a because, after that point, the
PCL render output fails when you specify external-graphic in the xsl with a
ArrayIndexOutOfBounds error. This worked perfectly with all versions upto 20.1a 
and before after which point the above error occurs. I have tried every 
distribution version of fop since to track down the exact point this problem 
started and what I state is it.

This is not a problem with a limited renderring engine as the response to 
#33164 states as it did work fine before with the same monochrome jpg images.
Comment 1 Pascal Sancho 2007-11-20 02:08:17 UTC
Fixed in FOP 0.94 and probably earlier versions
Comment 2 Glenn Adams 2012-04-01 06:32:58 UTC
batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed