Bug 34272 - Patch to externalize the JspServlet Options implementation
Patch to externalize the JspServlet Options implementation
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Jasper
5.5.9
Other other
: P2 enhancement (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-04-02 08:23 UTC by Scott M Stark
Modified: 2005-04-05 03:59 UTC (History)
0 users



Attachments
Patch for engineOptionsClass option patch (4.29 KB, patch)
2005-04-02 08:25 UTC, Scott M Stark
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scott M Stark 2005-04-02 08:23:35 UTC
Options like the tld cache cannot be set via external configuration. The
attached patch allows the org.apache.jasper.Options implementation used by the
JspServlet to be set via an engineOptionsClass parameter:

    <servlet>
        <servlet-name>jsp</servlet-name>
        <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
...
        <init-param>
            <param-name>engineOptionsClass</param-name>
           
<param-value>org.jboss.web.tomcat.tc5.jasper.JspServletOptions</param-value>
        </init-param>
        <load-on-startup>3</load-on-startup>
    </servlet>
Comment 1 Scott M Stark 2005-04-02 08:25:37 UTC
Created attachment 14608 [details]
Patch for engineOptionsClass option patch
Comment 2 Remy Maucherat 2005-04-04 00:52:04 UTC
It seems to add the original intended behavior of allowing plugging the options.
I'll commit your patch tomorrow.
Comment 3 Remy Maucherat 2005-04-05 11:59:07 UTC
I have applied the patch.