Bug 34312 - Provide a public method to Ant launcher in order to allow invoking Ant in the same JVM
Summary: Provide a public method to Ant launcher in order to allow invoking Ant in the...
Status: RESOLVED DUPLICATE of bug 29797
Alias: None
Product: Ant
Classification: Unclassified
Component: Other (show other bugs)
Version: 1.5.4
Hardware: Other All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: Ant Notifications List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-05 19:42 UTC by Onofrio Lazzizzera
Modified: 2008-02-22 12:18 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Onofrio Lazzizzera 2005-04-05 19:42:59 UTC
Provide a public method in the Ant launcher class (org.apache.tools.ant.Main in
version 1.5.4 but the mechanism is almost the same even in the latest version of
Ant) in order to allow invocation of Ant processing from a JVM without launching
another JVM process for Ant and letting the calling process continuing with its
execution after Ant processing is over.
In fact when the build file is processed a 

     System.exit(0)

invocation is done.
This enhancement does allow leveraging Ant powerful capabilities with minimizing
 usage of system resources.
Comment 1 Matt Benson 2005-05-28 00:28:43 UTC

*** This bug has been marked as a duplicate of 29797 ***