Bug 34577 - IIS 6.0 with isapi_redirect.dll (jk 1.2.10) filter does not log page requests
IIS 6.0 with isapi_redirect.dll (jk 1.2.10) filter does not log page requests
Status: RESOLVED FIXED
Product: Tomcat Connectors
Classification: Unclassified
Component: Common
unspecified
PC Windows Server 2003
: P2 enhancement (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-04-22 17:41 UTC by Haris Papadopoulos
Modified: 2008-10-05 03:09 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Haris Papadopoulos 2005-04-22 17:41:21 UTC
IIS logs do not contain any information about the page that Tomcat serves.
Instead, the following line: 
2005-04-21 14:58:12 192.168.1.59 GET /jakarta/isapi_redirect.dll - 80 -
192.168.1.11
Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US;+rv:1.7.5)+Gecko/20041107+Firefox/1.0
- 200 0 0

appears each time a redirection occurs.
I consider it a bug since one can not obtain useful Web statistics from IIS logs
or from Tomcat logs (static content gets logged by IIS while dynamic gets logged
by Tomcat).
Comment 1 Mladen Turk 2005-04-22 19:36:11 UTC
Hi,

This is not a bug, but rather enchantment request.
Neither JK nor JK2 never made any attempt to log a client
request inside IIS.
I'll see if some sort of logging can be made, but no premises :)

Regards,
Mladen.
Comment 2 Mladen Turk 2005-04-23 12:03:18 UTC
Added SF_NOTIFY_LOG for logging original request instead
logging isapi extension.
Comment 3 Haris Papadopoulos 2005-04-25 09:11:58 UTC
(In reply to comment #2)
> Added SF_NOTIFY_LOG for logging original request instead
> logging isapi extension.

I appreciate the immediate response. I aggree with you, it is not a bug, I just
had the impression that this feature existed once upon a time. 
So, how can we get our hands on the new version? Sorry for the impatience, but
this issue has troubled us for a long time.