Bug 34617 - Apache exits with status 3221225477
Summary: Apache exits with status 3221225477
Status: CLOSED INVALID
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.0.54
Hardware: PC Windows XP
: P1 critical (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-26 11:27 UTC by Nigel Jewell
Modified: 2005-08-14 05:13 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nigel Jewell 2005-04-26 11:27:32 UTC
Using:

Apache 2.0.54
mod_jk 1.2.8
Tomcat 5.0.28
PHP 4.3.10
mod_ssl 2.0.53
OpenSSL 0.9.7e

On Windows XP and Windows 2003 the server dies with the error:

Parent: child process exited with status 3221225477 -- Restarting.

The cause:  I have a PHP page that uses NuSOAP to connect to the server using a
mod_jk worker.  The worker uses Tomcat to obtain a large data set, which should
then be returned to the PHP page.  I suspect that the size of the data set that
is causing the server to fall over.  As the HTTP server falls over (rather than
report an error) it makes PHP/mod_jk/Tomcat/NuSOAP debugging difficult (if not
impossible).

In the mod_jk log I am also seeing:

could not find empty cache slot from 1 for worker ws01. Rise worker cachesize

I guess this may be related.
Comment 1 Nigel Jewell 2005-04-26 11:48:53 UTC
It should be noted - that if I increase the cachesize in mod_jk, the HTTP server
still falls over (although mod_jk no longer complains).  So this is probably a
red-herring.
Comment 2 Joe Orton 2005-04-28 17:25:20 UTC
A stack trace from the process crash or a precise repro case is needed to be
able to investigate this further.  I suggest you take this up on the appropriate
Jakarta list if you think it's caused by mod_jk.