Bug 34620 - Apache hangs when mod_ldap is loaded and use the PHP ldap functions
Summary: Apache hangs when mod_ldap is loaded and use the PHP ldap functions
Status: RESOLVED DUPLICATE of bug 34618
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ldap (show other bugs)
Version: 2.0.54
Hardware: Other Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-26 12:20 UTC by Justo Alonso
Modified: 2005-04-28 09:28 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justo Alonso 2005-04-26 12:20:53 UTC
I have an Apache 2.0.54 server with mod_ldap, mod_auth_ldap and libphp4 modules
loaded. When, from a PHP script open a connection to LDAP server, the first 2
times it works, but the third, the apache server process hangs.

I've tried it with Apache 1.3.27 and hungs, too. It seems like there's some kind
of conflict between mod_ldap and the php module, because when I disable mod_ldap
all works fine.

Openldap library: openldap2-client-2.1.12-44 (Suse release)

Apache config.nice file:
CFLAGS="-O2 -march=i486 -mcpu=i686 -fPIC -D_LARGEFILE_SOURCE
-DDYNAMIC_MODULE_LIMIT=72"; export CFLAGS
"./configure" \
"--enable-maintainer-mode" \
"--enable-layout=SuSE81" \
"--with-program-name=httpd2-leader" \
"--with-mpm=leader" \
"--with-perl=/usr/bin/perl" \
"--enable-mods-shared=all" \
"--enable-ssl=shared" \
"--disable-isapi" \
"--enable-deflate" \
"--enable-echo" \
"--enable-ext-filter" \
"--enable-charset-lite" \
"--enable-file-cache" \
"--enable-logio" \
"--enable-case_filter" \
"--enable-case_filter_in" \
"--with-ldap" \
"--enable-ldap" \
"--enable-auth_ldap" \
"--enable-proxy" \
"--enable-proxy-connect" \
"--enable-proxy-ftp" \
"--enable-proxy-http" \
"--enable-cache" \
"--enable-disk-cache" \
"--enable-mem-cache" \
"--enable-suexec" \
"--with-suexec-bin=/usr/sbin/suexec2" \
"--with-suexec-caller=wwwrun" \
"--with-suexec-docroot=/srv/www/htdocs" \
"--with-suexec-logfile=/var/log/apache2/suexec.log" \
"--with-suexec-userdir=public_html" \
"--with-suexec-uidmin=96" \
"--with-suexec-gidmin=96" \
"--with-suexec-safepath=/usr/local/bin:/usr/bin:/bin" \
"$@"
Comment 1 Justo Alonso 2005-04-26 13:18:43 UTC
Sorry I have the Apache process compiled in prefork mpm. The correct config.nice is:

CFLAGS="-O2 -march=i486 -mcpu=i686 -fPIC -D_LARGEFILE_SOURCE
-DDYNAMIC_MODULE_LIMIT=72"; export CFLAGS
"./configure" \
"--enable-maintainer-mode" \
"--enable-layout=SuSE81" \
"--with-program-name=httpd2-prefork" \
"--with-mpm=prefork" \
"--with-perl=/usr/bin/perl" \
"--enable-mods-shared=all" \
"--enable-ssl=shared" \
"--disable-isapi" \
"--enable-deflate" \
"--enable-echo" \
"--enable-ext-filter" \
"--enable-charset-lite" \
"--enable-file-cache" \
"--enable-logio" \
"--enable-case_filter" \
"--enable-case_filter_in" \
"--with-ldap" \
"--enable-ldap" \
"--enable-auth_ldap" \
"--enable-proxy" \
"--enable-proxy-connect" \
"--enable-proxy-ftp" \
"--enable-proxy-http" \
"--enable-cache" \
"--enable-disk-cache" \
"--enable-mem-cache" \
"--enable-suexec" \
"--with-suexec-bin=/usr/sbin/suexec2" \
"--with-suexec-caller=wwwrun" \
"--with-suexec-docroot=/srv/www/htdocs" \
"--with-suexec-logfile=/var/log/apache2/suexec.log" \
"--with-suexec-userdir=public_html" \
"--with-suexec-uidmin=96" \
"--with-suexec-gidmin=96" \
"--with-suexec-safepath=/usr/local/bin:/usr/bin:/bin" \
"$@"
Comment 2 Joe Orton 2005-04-28 17:28:27 UTC
Could you try this patch?

http://svn.apache.org/viewcvs/httpd/httpd/trunk/modules/ldap/util_ldap.c?rev=164919&r1=164918&r2=164919&view=diff

*** This bug has been marked as a duplicate of 34618 ***