Bug 34758 - Level should be made serializable
Level should be made serializable
Status: RESOLVED DUPLICATE of bug 26433
Product: Log4j
Classification: Unclassified
Component: Other
Other other
: P2 normal
: ---
Assigned To: log4j-dev
Depends on:
  Show dependency tree
Reported: 2005-05-05 14:49 UTC by Elias Ross
Modified: 2005-08-21 16:46 UTC (History)
0 users

Patch for Level.java (1.22 KB, patch)
2005-05-05 14:50 UTC, Elias Ross
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Ross 2005-05-05 14:49:35 UTC
Via JMX, I would like to control the threshold of appenders remotely.  This
requires Level to be serializble.

For JDK versions that don't support "readResolve()", this obviously wouldn't
have the desired behavior, but for those versions would continue to work
correctly.  I would simply make a note in the JavaDoc about it.

The Level-equivalent class in Java logging is serializable.
Comment 1 Elias Ross 2005-05-05 14:50:36 UTC
Created attachment 14939 [details]
Patch for Level.java
Comment 2 Curt Arnold 2005-08-22 00:46:04 UTC

*** This bug has been marked as a duplicate of 26433 ***