Bug 34836 - Xalan 1.9 crashes when initializing
Summary: Xalan 1.9 crashes when initializing
Status: RESOLVED INVALID
Alias: None
Product: XmlCommons - Now in JIRA
Classification: Unclassified
Component: DOM (show other bugs)
Version: 1.x
Hardware: Other Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: Commons Developers Mailing List
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2005-05-10 13:17 UTC by Marc
Modified: 2010-03-07 15:47 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc 2005-05-10 13:17:38 UTC
Hi All,
After downloading and compiling successfully Xerces 2.6 and Xalan 1.9, I got 
into problems when I try to use Xalan.
I just call:

XMLPlatformUtils::Initialize();
XalanTransformer::initialize();

and the second instruction crashes when calls DoubleSupport::initialize() 
function (the assignment s_NaN.d = sqrt(-2.01); causes a Unhandled exception: 
Floating-point invalid operation.)

I was using Xerces 2.5 with Xalan 1.8 without problems, and it was when I 
updated my code to 2.6 ans 1.9 when I got this problem.

Any idea? Am i doing something wrong?
I am compiling under Visual Studio .NET.
Thanks in advance,
Marc.
Comment 1 Michael Glavassevich 2010-03-07 15:47:40 UTC
This is a question about Xalan C++ not a bug report for XML Commons. You should ask your question on the appropriate mailing list [1] and if it turns out that there is a bug in Xalan C++ report it to the correct bug database and component [2].

Thanks.

[1] http://xml.apache.org/mail.html#xalan-c-users
[2] https://issues.apache.org/jira/browse/XALANC