Bug 34837 - ProxyRemote does not allow for basic authentication
Summary: ProxyRemote does not allow for basic authentication
Status: RESOLVED DUPLICATE of bug 25947
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy (show other bugs)
Version: 2.0-HEAD
Hardware: All All
: P3 normal with 4 votes (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on: 37355
Blocks:
  Show dependency tree
 
Reported: 2005-05-10 14:19 UTC by Stijn Maller
Modified: 2007-09-09 15:33 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stijn Maller 2005-05-10 14:19:49 UTC
Using the ProxyRemote directive to forward some of the traffic to another Proxy 
fails when the second Proxy requires the user to specify a username/password.

ProxyRequests On
ProxyVia On
ProxyRemote * http://proxy.externaltraffic.com:8080
NoProxy .my.intranetservers.com

Step 1: Client tries to access an external website
Step 2: Apache forwards the request to proxy.externaltraffic.com
Step 3: proxy.externaltraffic.com sends back Proxy-Authenticate header
Step 4: Apache passes Proxy-Authenticate header on to the client
Step 5: Client tries to access the external website again, adding the
Proxy-Authorization header
Step 6: Apache forwards the request to proxy.externaltraffic.com, but does not 
pass the Proxy-Authorization header, so instead of getting the content, we end 
up back at step 3.

Even when the header is explicitly set in Apache (RequestHeader set Proxy-
Authorization "Basic TEl34wRVNJkoFQm94QXBwMA==") it is still not sent to the 
external proxy.
Comment 1 Hendrik Harms 2006-05-31 06:32:10 UTC
The Proxy-Authenticate header was deleted by mod_proxy cause this header is an
"hop to hop" header. I got the same problem and build a patch for this. Have a
look on Bug 37355.
Comment 2 Nick Kew 2007-09-09 15:33:17 UTC
How does 37355 come into it?  That's about https vs http!

This looks to me more like PR 25947, which I committed a patch for this morning.
 Please reopen if you can convince me I'm wrong there!

*** This bug has been marked as a duplicate of 25947 ***